Forum

This forum is now read-only. Support is provided at https://wordpress.org/support/plugin/sermon-browser/

Please consider registering
guest
sp_LogInOut Log In sp_Registration Register
Register | Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_Feed Topic RSS sp_TopicIcon
Podcast Problems, not showing up on website or iTunes
3 November, 2013
12:12 am
Josh Lawrence
Member
Members
Forum Posts: 4
Member Since:
3 November, 2013
sp_UserOfflineSmall Offline

Hello

We are having problems with our podcast feed. Our website is http://www.zionequip.com, click on podcasts. We have been uploading for a while now and not had any problems. We did some updates and haven't been able to get podcasts to show up on our podcast page or in itunes. We have uploaded them as we always do. When we log in they appear in the backend but do not appear on the page or on iTunes.

We use Mozilla Firefox and Fireftp to upload to online server, and then pull from there into wordpress. Any guidance would be appreciated.

3 November, 2013
4:40 am
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

I'd like you to try adding a new test sermon with no MP3 file attached.  Go to Sermons, Add Sermon.  Enter in a Title, Preacher, Series, and Service.  Enter yesterday's date.  Leave the Bible passage and Attachments boxes empty.  Then click the Save button.

Next, go to Sermons, Options, and make sure that "Hide sermons without attachments?" is UNCHECKED.  Click the Save button on the Options page if you made any changes to the settings.

Finally, post back here, and I'll take another look.  If you haven't already, click the Subscribe button at the bottom of this forum topic, so you get an e-mail every time someone posts to your forum topic.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

3 November, 2013
3:18 pm
Josh Lawrence
Member
Members
Forum Posts: 4
Member Since:
3 November, 2013
sp_UserOfflineSmall Offline

Hi Ben,

Okay I created a sermon called Test. Under options the "Hide sermons without attachments" was already unchecked.

 

Thanks for your time

3 November, 2013
4:56 pm
Josh Lawrence
Member
Members
Forum Posts: 4
Member Since:
3 November, 2013
sp_UserOfflineSmall Offline

http://zionequip.com/podcasts/.....m.datetime

 

It does not show up on our wordpress site but when I click on the filtered sermons then "other" they show up.

3 November, 2013
6:56 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

Josh, I see that you are running the WP Super Cache plugin.  Go to Settings, WP Super Cache, choose "Caching Off" and click the Update Status button.  Next, click the Delete Cache button.  After you've done that, post back here, and I'll take another look.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

4 November, 2013
7:26 pm
Josh Lawrence
Member
Members
Forum Posts: 4
Member Since:
3 November, 2013
sp_UserOfflineSmall Offline

I did as you asked. 

4 November, 2013
8:12 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

Josh, thank you.  Your "test" sermon is now showing up on your "Podcasts" sermons page

WP Super Cache is the problem.  It is caching your sermons page, and it doesn't know that the page is updated when you add a new sermon.

The solution here is to tell WP Super Cache not to cache your sermons page.

Go to Settings, WP Super Cache.  Click on the Advanced tab, and scroll down to the "Accepted Filenames & Rejected URIs" heading.  You'll find a text box under that heading, and the description of the text box starts out "Add here stings (not a filename) that forces a page not to be cached."  In that box, add a line at the end of the list that contains the slug of your sermons page.  In your site's case, your new line will be this:

podcasts

After you've added that line, click the "Save Strings" button just below the text box.

 

After you've done that, you need to delete your cache to ensure that any old cache file for this page is removed.  Go to the Contents tab and click the "Delete Cache" button to clear out your cache.

 

Finally, you can turn caching back on, if you still have it disabled.  Click the Easy tab, choose "Caching On," and click the "Update Status" button to enable caching again on your site.

 

If you have any questions about this, please let me know.  Thank you to Rich Brown for telling me about this feature in WP Super Cache.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

Forum Timezone: Europe/London
Most Users Ever Online: 381
Currently Online:
Guest(s) 4
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Rich Brown: 358
Matt Schlueter: 93
Mindy: 72
Don Johnson: 65
anointed: 57
0be1: 55
Member Stats:
Guest Posters: 7
Members: 3188
Moderators: 1
Admins: 1
Forum Stats:
Groups: 1
Forums: 2
Topics: 1713
Posts: 7499
Newest Members:
marktest, deatles50, ValeriaGoodriz, dapedPup, oapedPup, Margarettoimb
Moderators: Ben Miller: 1628
Administrators: Mark Barnes: 435