Forum

This forum is now read-only. Support is provided at https://wordpress.org/support/plugin/sermon-browser/

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
No Player
3 July, 2014
4:09 pm
drewk
New Member
Members
Forum Posts: 2
Member Since:
13 January, 2011
sp_UserOfflineSmall Offline

We've been using sermon browser for a while and all the sudden the posts won't show the audio player for the uploaded sermon.
I check to see that there is enough disk space. I've tried using a very small mp3 to make sure it wasn't the file size. I can create a new sermon, but the player just doesn't show anymore.

http://www.nlicc.org/services/.....mon_id=180

6 July, 2014
11:07 pm
Daniel Saunders
Enthusiast
Members
Forum Posts: 25
Member Since:
4 February, 2013
sp_UserOfflineSmall Offline

Have you updated anything on the website recently - version of wordpress? other plugins?

I'm no expert, but when I used firebug (http://getfirebug.com) to look at the section of the page where I would have expected code for the player/downloading audio there was nothing. Have you changed the sermon template recently?

13 August, 2014
6:59 pm
Scott150
McCaysville, Georgia USA
Enthusiast
Members
Forum Posts: 20
Member Since:
8 January, 2014
sp_UserOfflineSmall Offline

I am, all of a sudden, having the same issue.
Using Firebug, I discovered that the entire division class of "sermon_file" to be missing.
On a sermon page with the player showing the code is as follows:

On a sermon page without the player showing the entire "

", which contains a bunch of code, is simply not there.

For what its worth, and one thing may not have anything to do with the other, my problem started when I attempted to add a PDF attachment to a sermon.
I added it but it didn't do what I thought it should so I deleted it. Ever since then, I haven't been able to add a sermon that would show the player.

I have tried repairing all of the SQL files as well as deactivating and the reactivating the plugin, but the problem remains. I've made no changes to either the template or the CSS files.

If I were to uninstall/reinstall the plugin do you suppose that would correct the problem? I have a backup off the database that I could restore in order to not lose anything.

Any help would be appreciated. I've been using Sermon Browser for quite awhile with no problems until now.

13 August, 2014
7:08 pm
Scott150
McCaysville, Georgia USA
Enthusiast
Members
Forum Posts: 20
Member Since:
8 January, 2014
sp_UserOfflineSmall Offline

I did not realize that the HTML code would be dropped from my last post, so perhaps if I use the HTML comment tag it it will print.

Here goes:

<!--

* *
-->

When the player doesn't show the "

" section is missing.
13 August, 2014
7:09 pm
Scott150
McCaysville, Georgia USA
Enthusiast
Members
Forum Posts: 20
Member Since:
8 January, 2014
sp_UserOfflineSmall Offline

I give up. How would you show HTML coding in a post?

16 August, 2014
1:22 pm
Daniel Saunders
Enthusiast
Members
Forum Posts: 25
Member Since:
4 February, 2013
sp_UserOfflineSmall Offline

Scott150 said

I give up. How would you show HTML coding in a post?

Try http://www.pastebin.com ?

16 August, 2014
5:57 pm
Scott150
McCaysville, Georgia USA
Enthusiast
Members
Forum Posts: 20
Member Since:
8 January, 2014
sp_UserOfflineSmall Offline

I am attempting to use Paste Bin suggestion to show the HTML code.

Is this a good link? http://www.pastebin.com/jXwqYn4d

If I backup the SQL file(s) may I uninstall Sermon Browser, then reinstall it and restore the SQL files without losing any data?

18 August, 2014
3:16 pm
Scott150
McCaysville, Georgia USA
Enthusiast
Members
Forum Posts: 20
Member Since:
8 January, 2014
sp_UserOfflineSmall Offline

Scott150 said

I am attempting to use Paste Bin suggestion to show the HTML code.
Is this a good link? http://www.pastbin.com/jXwqYn4d
If I backup the SQL file(s) may I uninstall Sermon Browser, then reinstall it and restore the SQL files without losing any data?

Checked the pastebin.com link and it goes to an advertisement, so link is no good. Sorry about that.

Since this post, I backed up my SQL database, uninstalled and deleted Sermon Browser. I then did a clean reinstall and activated the latest version Sermon Browser and restored my original SQL database.

Absolutely NADA. Same problem as before, which, at least to me, indicates that it has to be inherent in the SQL database. A pointer has gotten out of whack somehow. I checked the DB and it reports everything is good. The only question I have is why the original collation would be "latin1_swedish_ci". Anyone know?

Unless someone has a really good idea in the next little while, I'm thinking that I'm going to have to reinstall and add all of the sermons all over again. I hate losing the download stats. Perhaps I'll add those manually.
frown

20 August, 2014
7:37 pm
Scott150
McCaysville, Georgia USA
Enthusiast
Members
Forum Posts: 20
Member Since:
8 January, 2014
sp_UserOfflineSmall Offline

I have not yet found any reason nor a solution to the problem of adding new sermons, however I have found a workaround: The problem appears to be that Sermon Browser is adding only the file name to the "wp_sp_stuff" SQL table and, in order for the player and sermon to be found, this table needed a link back to the sermon via the sermon ID.

The sermon ID can be found in the "wp_sp_sermons" table in the ID field. Add this ID to the "sermon_id" field in the "wp_sp_stuff" table and the sermon will appear, with an audio player. While you're there, you might want to add the "duration" also, but it's not required.

I don't know why SB stopped filling in these fields correctly as it obviously had access to the database or it couldn't have inserted the file name. Anyone have a suggestion as to what went wrong?

10 September, 2014
9:17 am
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

Scott150,

I haven't yet been able to duplicate this problem.  What version of PHP and mySQL are you running on your site?

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

10 September, 2014
2:13 pm
Scott150
McCaysville, Georgia USA
Enthusiast
Members
Forum Posts: 20
Member Since:
8 January, 2014
sp_UserOfflineSmall Offline

Ben Miller said

Scott150,
I haven't yet been able to duplicate this problem.  What version of PHP and mySQL are you running on your site?

Thanks for the reply. As always, its good to her from someone that knows what's what.

According to the server, I'm running the following:
Apache version: 2.2.27
PHP version: 5.4.31
MySQL version: 5.5.36-cll
Architecture: x86_64
Operating system: Linux

As of now, adding a sermon appears to work, but doesn't as Sermon Browser still fails to insert the sermon ID# into the "wp_sb_stuff" SQL table. My workaround of getting the sermon ID number from "wp_sb_sermons" and manually inserting it (and the file duration) into "wp_sb_stuff" is working. Kind of a pain, but it does get it operating as it is supposed to.

22 October, 2014
10:59 pm
sunsetparkcc
New Member
Members
Forum Posts: 1
Member Since:
22 October, 2014
sp_UserOfflineSmall Offline

Anyone find a good fix for this? I have been trying to figure out why sermon browser stopped functioning some time back. It appears it is similar to this issue mentioned in this forum. The url to review is: http://sunsetparkcc.com/sermons/

 

All of the previously working sermons that showed the player before no longer show anything for the media file other than a download link. I am about to ditch Sermon Browser due to the issue and rebuild the site at this rate as there seem to be no real answers. 

Anyone have any decent suggestions outside of re-coding? 

Forum Timezone: Europe/London

Most Users Ever Online: 381

Currently Online:
20 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Rich Brown: 358

Matt Schlueter: 93

Mindy: 72

Don Johnson: 65

anointed: 57

0be1: 55

Member Stats:

Guest Posters: 7

Members: 3188

Moderators: 1

Admins: 1

Forum Stats:

Groups: 1

Forums: 2

Topics: 1713

Posts: 7499

Newest Members:

marktest, deatles50, ValeriaGoodriz, dapedPup, oapedPup, Margarettoimb

Moderators: Ben Miller: 1628

Administrators: Mark Barnes: 435