Forum

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
How to override PHP settings in hosted environment?
29 January, 2015
5:15 pm
DaiBo
New Member
Members
Forum Posts: 1
Member Since:
29 January, 2015
sp_UserOfflineSmall Offline

** I posted this topic on wordpress.org and I am reposting here because this forum seems to be more active.

I have a multisite installation in a hosted environment.

I need to increase the max file upload size to the following (suggested by the Sermon Browser FAQ):

file_uploads = On
upload_max_filesize = 15M
post_max_size = 15M
max_execution_time = 600
max_input_time = 600
memory_limit = 48M

My restrictions:
1. The only access I have to the file system is through FTP.
2. The path structure in FTP is: /wordpress/wp-admin/ I don't have access to files above the FTP root level.
3. I don't have access to the system's php.ini file.
4. The system is running on Windows IIS.
5. The PHP version is 5.2.x.

What can I do to override these settings? I tried putting these settings into a php5.ini file in a few folders from FTP root to wp-admin, and when I opened up the wordpress site on the browser, the only thing I got is the line:
"Your PHP installation appears to be missing the MySQL extension which is required by WordPress."

All I want to do is to override the few settings listed above without changing any other configuration.

Please let me know what I need to do.

29 January, 2015
6:44 pm
Extrafino
Enthusiast
Members
Forum Posts: 43
Member Since:
5 July, 2013
sp_UserOfflineSmall Offline

I think you are asking in the wrong forum again. You should contact your hoster directly or read through your hoster's FAQ.

PHP can be run in a variety of ways and if your hoster does not allow you to change your settings, you will not be able to do it in any other way but asking.

On my hoster I have to upload a complete php.ini with all settings and not just the settings I want to change, but that really depends.

11 February, 2015
6:28 pm
Wilma Feather
New Member
Members
Forum Posts: 1
Member Since:
11 February, 2015
sp_UserOfflineSmall Offline

A php.ini in /wp-admin with these two lines increases upload size for me on 1and1

upload_max_filesize = 24M
post_max_size = 24M

I need both lines to accommodate long sermons and large images.

Forum Timezone: Europe/London

Most Users Ever Online: 381

Currently Online:
19 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Rich Brown: 358

Matt Schlueter: 93

Mindy: 72

Don Johnson: 65

anointed: 57

0be1: 55

Member Stats:

Guest Posters: 7

Members: 3187

Moderators: 1

Admins: 1

Forum Stats:

Groups: 1

Forums: 2

Topics: 1713

Posts: 7499

Newest Members:

deatles50, ValeriaGoodriz, dapedPup, oapedPup, Margarettoimb, ShumaneAncet

Moderators: Ben Miller: 1628

Administrators: Mark Barnes: 435