Forum

This forum is now read-only. Support is provided atย https://wordpress.org/support/plugin/sermon-browser/

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
"Audio clip: Adobe Flash Player (version 9 or above) is required to play this audio clip..."
5 January, 2010
10:21 pm
Rich Brown
Parkville, MD
Guru
Members
Forum Posts: 358
Member Since:
13 July, 2009
sp_UserOfflineSmall Offline

When I install the newest Audio Player, instead of the player, I get, "Audio clip: Adobe Flash Player (version 9 or above) is required to play this audio clip. Download the latest version here. You also need to have JavaScript enabled in your browser." I get this is IE (all versions), FireFox, Opera, and Chrome.

I went to their website and they know about this error. They state that I should add some code to the header and the footer, which I have done โ€” and it still doesn't work. I have also deleted and re-installed, to no avail. I tried to download the previous version but the download links on the site only have the current version. My site is at http://sermons.aisquith.org

Help!

EDIT: I was able to roll back to version 1.2.3 but I still can't get 2.02 to work.

Rich Brown
Aisquith Presbyterian Church
Parkville, Maryland, USA
sermons.aisquith.org

6 January, 2010
1:38 pm
jeremyt323
New Member
Members
Forum Posts: 1
Member Since:
6 January, 2010
sp_UserOfflineSmall Offline

I'm having the exact same issue with my site. I have the header and footer call tags in place as the audio player website describes, but still no help with the error message above. The audio section of my site is: http://www.thepointcommunity.n.....h/sermons/

Any ideas out there? Is this a Sermon Brower/Audio Player conflict? I would imagine there must be others out there having this issue...

Thanks in advance.

-Jeremy

6 January, 2010
5:36 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

Jeremy, the reason that your Audio Players are not displaying is that there is some code missing in the footer. I tested this by downloading your sermon page code, inserting the code myself, and running it locally, and I was able to get the player to appear. The code that is missing is something like this:

<script type="text/javascript">
AudioPlayer.embed("audioplayer_1", {soundFile:"SomeSoundFileIdentifierHere"});
</script>

When I insert this code toward the bottom of your page, the first player appears. For the other players, other lines just like this one will also be inserted.

This code is normally inserted automatically when the footer call code is executed. As you said, it looks like you've already got this in place. So why is the Audio Player plugin not inserting that code into the footer? I don't know. I would post a link to your site (and maybe this forum topic) on the Audio Player plugin forum here and see if the plugin author has any ideas.

webservant, I'm guessing that you had the same issue going on, but I wasn't able to look at it before you switched to 1.2.3. I'm running 1.2.3 on my site as well, and I haven't had this problem.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

6 January, 2010
11:35 pm
Rich Brown
Parkville, MD
Guru
Members
Forum Posts: 358
Member Since:
13 July, 2009
sp_UserOfflineSmall Offline

I inserted that code, and the search page displayed a player in the very first sermon, but the same Flash error message on all the other ones after it. The first player would display "file not found" when I pressed play. I restored the old version.

I inserted the code in several different places in the footer, and got the same result each time.

Rich Brown
Aisquith Presbyterian Church
Parkville, Maryland, USA
sermons.aisquith.org

7 January, 2010
3:15 am
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

webservant, unfortunately, inserting the code manually isn't the solution to the problem. The code needs to be inserted by the Audio Player plugin itself. The reason you got "file not found" was because the Sound File Identifier wasn't correct. (The Audio Player plugin puts something in here to point to the sound file.)

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

8 January, 2010
12:49 am
sdgstudios
Member
Members
Forum Posts: 3
Member Since:
8 January, 2010
sp_UserOfflineSmall Offline

i am having the same problem. would really like to use this on our church site. someone fix it! ๐Ÿ™‚

8 January, 2010
12:56 am
Rich Brown
Parkville, MD
Guru
Members
Forum Posts: 358
Member Since:
13 July, 2009
sp_UserOfflineSmall Offline

SDG, 1.2.3 isn't that bad - it just lacks a volume control.

Rich Brown
Aisquith Presbyterian Church
Parkville, Maryland, USA
sermons.aisquith.org

11 January, 2010
6:33 pm
ardesmond
New Member
Members
Forum Posts: 2
Member Since:
23 December, 2009
sp_UserOfflineSmall Offline

Did anyone get this working?

11 January, 2010
6:59 pm
Rich Brown
Parkville, MD
Guru
Members
Forum Posts: 358
Member Since:
13 July, 2009
sp_UserOfflineSmall Offline

Ardesmond - I reverted to 1.2.3. I couldn't get 2+ to work, and I even corresponded with the developer. This is not a Sermon Browser issue. Certain themes just don't work with 2+.

Rich Brown
Aisquith Presbyterian Church
Parkville, Maryland, USA
sermons.aisquith.org

11 January, 2010
7:03 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

It looks like jeremyt323 was able to get the 2.0 beta 6 version working on his site. The Audio Player plugin developer recently made the 2.0 beta 6 version available again, which you can download here. If you are having trouble with 2.0.2, maybe beta 6 will work for you.

It looks like not everyone is having trouble with Audio Player 2, but some are.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

11 January, 2010
7:38 pm
Rich Brown
Parkville, MD
Guru
Members
Forum Posts: 358
Member Since:
13 July, 2009
sp_UserOfflineSmall Offline

Ben - actually that version did work for me but I couldn't find a link to download it. The beta is different from the release version in that it, evidently, does not write anything into the footer. Thanks!

Rich Brown
Aisquith Presbyterian Church
Parkville, Maryland, USA
sermons.aisquith.org

11 January, 2010
8:05 pm
Matt Schlueter
Dodgeville, WI USA
Guru
Members
Forum Posts: 93
Member Since:
19 November, 2009
sp_UserOfflineSmall Offline

Well, the AudioPlayer plugin seems to be really finicky when combined with other plugins, even those that seem relatively unrelated (like, when I installed a login-page plugin, audioplayer broke).

I am currently running Wordpress 2.9.1, Sermon Browser 0.43.5, and Audio Player 2.0.2 (all latest versions as of this writing), and it's all working perfectly.

It doesnt seem to be a direct problem with SermonBrowser and Audio Player... but with AudioPlayer and other random plugins.

Matt Schlueter, Multimedia Coordinator
Dodgeville United Methodist Church -- Dodgeville, WI

Forum Timezone: Europe/London

Most Users Ever Online: 381

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Rich Brown: 358

Matt Schlueter: 93

Mindy: 72

Don Johnson: 65

anointed: 57

0be1: 55

Member Stats:

Guest Posters: 7

Members: 3188

Moderators: 1

Admins: 1

Forum Stats:

Groups: 1

Forums: 2

Topics: 1713

Posts: 7499

Newest Members:

marktest, deatles50, ValeriaGoodriz, dapedPup, oapedPup, Margarettoimb

Moderators: Ben Miller: 1628

Administrators: Mark Barnes: 435