Forum

This forum is now read-only. Support is provided at https://wordpress.org/support/plugin/sermon-browser/

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
45.12 Audio file buffering, not playing
16 December, 2013
7:37 am
BethAriel
Member
Members
Forum Posts: 5
Member Since:
16 December, 2013
sp_UserOfflineSmall Offline

Our church website is http://www.bethariel.org. I just recently updated the Sermon Browser plugin to 0.45.12. The Wordpress version is still 3.0.4; I was planning to upgrade it to 3.8. But currently, when one clicks to play the audio player, the message says "buffering", but the file will not play. What should I do? Do I need to adjust something in the code, or swap a file via php? The audio player plugin is ver. 2.0.4.6. The URL for the mp3 files are working fine elsewhere. Thank you. Please respond as soon as possible.

16 December, 2013
6:08 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

BethAriel,

The problem is that your "MP3 Shortcode" setting (in Sermons, Options) does not match what it needs to be for your Audio Player plugin.

The old Audio Player plugin is not something I recommend any longer.  However, if you want to continue to use it, just go to Sermons, Options and change your "MP3 Shortcode" setting to this:

(left-square-bracket)audio:%SERMONURL%(right-square-bracket)

Note: the square bracket characters [ ] cause problems here on the forum, so I couldn't type them in the shortcode setting above.  Use the actual square bracket characters in place of the bold text.

 

If you want to use a more modern player that will work with mobile devices, read the forum FAQ and find the question "I want to use a media player that works on Apple devices."  After you read that, if you have any questions, please let me know.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

30 December, 2013
8:25 am
BethAriel
Member
Members
Forum Posts: 5
Member Since:
16 December, 2013
sp_UserOfflineSmall Offline

Ben Miller said
BethAriel,
The problem is that your "MP3 Shortcode" setting (in Sermons, Options) does not match what it needs to be for your Audio Player plugin.
The old Audio Player plugin is not something I recommend any longer.  However, if you want to continue to use it, just go to Sermons, Options and change your "MP3 Shortcode" setting to this:
(left-square-bracket)audio:%SERMONURL%(right-square-bracket)
Note: the square bracket characters [ ] cause problems here on the forum, so I couldn't type them in the shortcode setting above.  Use the actual square bracket characters in place of the bold text.
 
If you want to use a more modern player that will work with mobile devices, read the forum FAQ and find the question "I want to use a media player that works on Apple devices."  After you read that, if you have any questions, please let me know.

Ben,

In reply to your previous response, and reading the suggested forum topics,
I decided to upgrade my wordpress to ver. 3.8 and utilize the built-in audio
player (js.mediaelement). That seemed to solve the problem, at least so I
thought. The mp3's are correctly inserted into the sermon browser pages only
on Firefox and Google Chrome browsers. However, as shown in the attached
screenshot, something is not working in Internet Explorer (ver. 8 and 10),
and Safari. The mp3 shortcode that I'm using is audio [mp3=:%SERMONURL%].

Thank you,

Scott Seiden
http://www.bethariel.org

30 December, 2013
2:21 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

Scott,

First, are you running a plugin called Ultimate Google Analytics?  If you are, please deactivate that plugin (don't delete or uninstall, just deactivate), then post back here, and I'll take another look at your site.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

30 December, 2013
2:50 pm
BethAriel
Member
Members
Forum Posts: 5
Member Since:
16 December, 2013
sp_UserOfflineSmall Offline

Ben Miller said
Scott,
First, are you running a plugin called Ultimate Google Analytics?  If you are, please deactivate that plugin (don't delete or uninstall, just deactivate), then post back here, and I'll take another look at your site.

Ben,

I deactivated that plugin, but it did not solve the problem. I appreciate the help.

Scott.

 

30 December, 2013
6:06 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

Scott,

I suspect that your theme, parallelus-traject, has some logic in it that is causing problems in Internet Explorer. 

To test this, temporarily switch your website to one of the default themes (TwentyEleven, TwentyTwelve, or TwentyThirteen) and see if the problem goes away.  If so, that confirms that something in your theme is causing the problem.  If it doesn't go away after switching themes, it could be one of your plugins causing the problem.  You can temporarily deactivate all of your plugins (except Sermon Browser) and see if the problem goes away.

I am using IE 11 on Windows 7, and I did see the problem on your website, but not on other websites using Sermon Browser.  To troubleshoot, I hit the F12 key, then scrolled down to the "Emulation" screen.  There is a setting there called "Document mode."  On your website, the default is "7."  (On my test website using the TwentyThirteen theme, the default is "Edge.")  On your website, when I changed the Document mode to 9, 10, or Edge, the problem was fixed.  There is something in your code (most likely in your theme) that is forcing Internet Explorer into Document mode 7 and preventing the MediaElement.js player from working correctly. 

I'm not an IE compatibility expert, but here is what I've learned to do.

Microsoft runs a website called "modern.IE" that will scan your webpage and look for potential problems.  Here is a scan of one of your sermon pages.  A couple of things jump out at me: the Compatibility Mode that apparently your theme is using, and an old version of jQuery that your theme is installing.

After you've confirmed that switching your theme fixes the problem you are seeing, I think your next step is to talk to your theme developer.  Feel free to point them to this forum post to give them a starting point.  If you have any more questions for me, feel free to ask.  Please let me know what you find out.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

9 January, 2014
1:42 am
BethAriel
Member
Members
Forum Posts: 5
Member Since:
16 December, 2013
sp_UserOfflineSmall Offline

Ben Miller said
Scott,
I suspect that your theme, parallelus-traject, has some logic in it that is causing problems in Internet Explorer. 
To test this, temporarily switch your website to one of the default themes (TwentyEleven, TwentyTwelve, or TwentyThirteen) and see if the problem goes away.  If so, that confirms that something in your theme is causing the problem.  If it doesn't go away after switching themes, it could be one of your plugins causing the problem.  You can temporarily deactivate all of your plugins (except Sermon Browser) and see if the problem goes away.
I am using IE 11 on Windows 7, and I did see the problem on your website, but not on other websites using Sermon Browser.  To troubleshoot, I hit the F12 key, then scrolled down to the "Emulation" screen.  There is a setting there called "Document mode."  On your website, the default is "7."  (On my test website using the TwentyThirteen theme, the default is "Edge.")  On your website, when I changed the Document mode to 9, 10, or Edge, the problem was fixed.  There is something in your code (most likely in your theme) that is forcing Internet Explorer into Document mode 7 and preventing the MediaElement.js player from working correctly. 
I'm not an IE compatibility expert, but here is what I've learned to do.
Microsoft runs a website called "modern.IE" that will scan your webpage and look for potential problems.  Here is a scan of one of your sermon pages.  A couple of things jump out at me: the Compatibility Mode that apparently your theme is using, and an old version of jQuery that your theme is installing.
After you've confirmed that switching your theme fixes the problem you are seeing, I think your next step is to talk to your theme developer.  Feel free to point them to this forum post to give them a starting point.  If you have any more questions for me, feel free to ask.  Please let me know what you find out.

Ben, I communicated the issue with Parallelus, and they suggested modifying the button-styles codes in the onload.js file. Since that is a little above my knowledge level, I decided to find a work-around solution. I started manually entering the sermon info with a direct line insert for the audio player, then something weird happened. When I put the audio shortcode above (but not below) the SermonBrowser shortcode on a page, all the players started working in IE.

I figured it out! After checking the source for both the Media Element audio player and the Sermon Browser player, I noticed the difference. The following code precedes the Media Element audio player.

<!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]-->

When I inserted the code above the Sermon Browser shortcode on the page, that solved the problem without having to enter the full Media Element shortcode.
Thanks, Scott.

5 November, 2014
5:01 pm
terrykemm
Bloomsburg, PA
Member
Members
Forum Posts: 7
Member Since:
19 October, 2013
sp_UserOfflineSmall Offline

FYI - I install Audio Player and it created this same problem.  Deactivated it and the player worked again,

 

Terry

Forum Timezone: Europe/London

Most Users Ever Online: 381

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Rich Brown: 358

Matt Schlueter: 93

Mindy: 72

Don Johnson: 65

anointed: 57

0be1: 55

Member Stats:

Guest Posters: 7

Members: 3188

Moderators: 1

Admins: 1

Forum Stats:

Groups: 1

Forums: 2

Topics: 1713

Posts: 7499

Newest Members:

marktest, deatles50, ValeriaGoodriz, dapedPup, oapedPup, Margarettoimb

Moderators: Ben Miller: 1628

Administrators: Mark Barnes: 435