Forum

This forum is now read-only. Support is provided at https://wordpress.org/support/plugin/sermon-browser/

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Mini Player not Working
28 June, 2013
11:53 am
gatewaycc
Member
Members
Forum Posts: 3
Member Since:
28 June, 2013
sp_UserOfflineSmall Offline

Hi,

    The mini player in the widget stopped working recently.  It just spins around.  In another thread it was suggested to make sure the uploads path was /wp-content/uploads/sermons/.  I added the forward slash in front of the wp directory.  Still no good.  The player used to work fine, but about two weeks ago we upgraded to the latest version of the plugin, yet i'm sure it worked as recently as last week.  Our sermons are actually not in the sermons directory, but broken down into subdirectories by service day, such as sermons/sundayam, sermons/sundaypm, sermons/wednesdaypm.  Would that be causing this, even though it worked previously? 

Thanks in advance.  Our website url is http://www.gatewaychristianchurch.com

 

 

28 June, 2013
4:04 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

The first problem I see is that you have a problem with your most recent sermon.  The URL you entered for the sermon file is incorrect.  Edit your most recent sermon and fix the Attachment URL.  Then post back here and I'll take another look.  Let me know if you have any questions.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

28 June, 2013
4:52 pm
gatewaycc
Member
Members
Forum Posts: 3
Member Since:
28 June, 2013
sp_UserOfflineSmall Offline

Thank you, Ben. I fixed that link. 

28 June, 2013
5:55 pm
Ben Miller
Appleton, WI, USA
Moderator
Members

Moderators
Forum Posts: 1628
Member Since:
18 June, 2009
sp_UserOfflineSmall Offline

I found the problem.  This bug was introduced in the last version, 0.45.8.  Sorry!  Here is the fix:

In frontend.php, function sb_first_mp3, line 1112:

OLD line:

http://pastebin.com/yvtqmZ2B

NEW line:

http://pastebin.com/ruq0iXQb

 

I'll put this fix into the next version of Sermon Browser, but if you put the fix in yourself before that, let me know how it works for you.  If you have any questions, feel free to ask.  Thanks.

Ben Miller, Pathways Church, Appleton, Wisconsin, USA
Read the new FAQ, last updated 11/21/2013
Announcing version 0.45.12

29 June, 2013
6:41 pm
gatewaycc
Member
Members
Forum Posts: 3
Member Since:
28 June, 2013
sp_UserOfflineSmall Offline

Thanks, Ben! That worked.  No apologies needed.  Sermon Browser is great and you are very helpful.  thanks for everything.

Forum Timezone: Europe/London

Most Users Ever Online: 381

Currently Online:
15 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Rich Brown: 358

Matt Schlueter: 93

Mindy: 72

Don Johnson: 65

anointed: 57

0be1: 55

Member Stats:

Guest Posters: 7

Members: 3188

Moderators: 1

Admins: 1

Forum Stats:

Groups: 1

Forums: 2

Topics: 1713

Posts: 7499

Newest Members:

marktest, deatles50, ValeriaGoodriz, dapedPup, oapedPup, Margarettoimb

Moderators: Ben Miller: 1628

Administrators: Mark Barnes: 435